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1.  Software Description, Installation and Setup 

1.1 Description 

 The PickAtlas software toolboxes [1, 2] provide methods for generating ROI masks based on 

the Talairach Daemon (TD) database [3, 4] as well as other human and non-human animal 

atlases,  and exploring analysis results.  The TD atlases include Brodmann area, Lobar, 

Hemisphere, Anatomic Label (gyral anatomy) and Tissue Type.  The atlases have been extended 

to the vertex in MNI space (see Atlas Modifications under Technical Notes). Other atlases 

included in this release are the AAL atlas, ICBM label atlas, the UNC primate Brain Atlas 

(rhesus), the Virginia Tech/Wake Forest Vervet atlas, and the Brookhaven National Laboratory 

Mouse Atlas.  Additional atlases can be added without much difficulty (see Developer’s 

manual).  The toolbox was developed in the ANSIR Laboratory at the Wake Forest University 

School of Medicine.  Questions can be referred to maldjian@wfubmc.edu . 

1.2 Hardware and Software Requirements 

Matlab 

 The wfu_pickatlas toolboxes require at least Matlab 2008a. 

SPM 

The wfu_pickatlas and wfu_results toolboxes can run outside of SPM.  All toolboxes are 

compatible with SPM8 (from the Wellcome Trust Centre for Neuroimaging, London, 

UK).  

Linux 

The toolbox has been evaluated on Linux platforms.   

Windows 

It has not been extensively evaluated for Windows. The minimum screen resolution must 

be 1280x1024 or all the buttons will not appear.   

1.3 Program Installation 

 The WFU_PickAtlas toolbox can be obtained at www.ansir.wfubmc.edu . 

 

 Uncompress and untar the the gz file in a temporary location.  

 

 Copy the wfu_pickatlas, wfu_results, and wfu_tbx_common directories to the toolbox 

directory of your SPM installation. 

 

 If  you are using WINZIP to extract the tar file version of the distribution, you must turn off 

the “Tar file smart CR/LF conversion option” (found under Options, Configuration, 

Miscellaneous, Other).  If this option is not turned off, the wfu_pickatlas.fig will be corrupted 

and the program will not start.  

   

 This will create several subdirectories called wfu_pickatlas, wfu_results, and 

wfu_tbx_common in your SPM toolbox directory.  When run from the SPM Toolboxes pull-

down menu, the appropriate toolbox path will be automatically prepended to the current Matlab 

path.   

mailto:maldjian@wfubmc.edu
http://www.fil.ion.ucl.ac.uk/spm/
http://www.ansir.wfubmc.edu/
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To run from the command line without first accessing the program from the SPM Toolboxes 

pull-down list, you will need to set your Matlab path to directly access the wfu_pickatlas 

directory:  

 

Adding the WFU_PickAtlas toolboxes to the path 
addpath(SPMpath/toolbox/wfu_pickatlas);  

 

If the software is installed properly, you should be able to call up the graphical user interface 

(GUI) from the Matlab command prompt with: 

 

Lauching the PickAtlas from the Matlab command prompt 
wfu_pickatlas; 

 

  

1.4 Referencing the software 

When using this tool for a paper please reference [1, 2]: 

 

Maldjian, JA, Laurienti, PJ, Burdette, JB, Kraft RA.  An Automated Method for 

Neuroanatomic and Cytoarchitectonic Atlas-based Interrogation of fMRI Data Sets. 

NeuroImage 2003. 19:1233-1239. 

 

Maldjian JA, Laurienti PJ, Burdette JH.  Precentral Gyrus Discrepancy in Electronic 

Versions of the Talairach Atlas.  Neuroimage 2004; 21(1) 450-455.   

      

The above manuscripts provide a complete description of how the atlas volumes were 

generated and validated.  If using any of the Talairach Daemon database atlases, please reference 

[3, 4]: 

 

Lancaster JL, Summerln JL, Rainey L, Freitas CS, Fox PT. The Talairach Daemon, a 

database server for Talairach Atlas Labels. NeuroImage 1997;5:S633 

 

Lancaster JL, Woldorff MG, Parsons LM, et al. Automated Talairach atlas labels for 

functional brain mapping. Hum Brain Mapp 2000;10:120-131 

 

If using the included aal atlas, please also reference [5]: 

 

Tzourio-Mazoyer N, Landeau B, Papathanassiou D, Crivello F, Etard O, Delcroix N, 

Mazoyer B, Joliot M. Automated anatomical labeling of activations in SPM using a 

macroscopic anatomical parcellation of the MNI MRI single-subject brain. Neuroimage. 

2002; 15(1):273-89. 

 

For other atlases please reference the sources cited in the pickatlas GUI using the “atlas 

information” button at the bottom of the left atlas selection pane.
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2. Using the WFU_PickAtlas 

2.1 GUI layout 

The PickAtlas tool is divided 

into 3 primary columns (Figure 1). 

The left most column includes the 

atlases that can be used to generate 

a mask. The right most column is 

the working region that lists the 

areas to be included in the mask. 

The center column includes 

function buttons and an anatomic 

image with the selected mask 

overlaid. The lower most portion 

of the tool includes coordinate 

conversions and Talairach Daemon 

labels for any point that is chosen 

on the anatomic image as 

described below. The title bar of 

the left window reports the atlas in 

use. By double clicking on one of 

the atlases (i.e,. Brodmann area+), 

the corresponding subregions are 

listed and the title bar updates to 

display that the Brodmann Area 

atlas is selected.  Double clicking 

on any of the subregions moves it 

to the working regions pane 

(right).  In Basic mode, anything in 

the working region pane is automatically added to the mask and all operations are considered 

unions.  In Advanced mode (see Figure 6), unions, intersections, and multiple combinations of 

regions are allowed. In advanced mode, the commit button must be pressed (appears under the 

working region pane) before an ROI is added to the final mask.  Both Basic and Advanced mode 

allow the use of the dilation operator. The default operation is for a mask to be written with a 

single value for the masked region (a value of 1).  The “Write Independent Regions” selector 

assigns a unique value to each region in the mask (up to 255).  

The bottom of the GUI contains a coordinate converter for converting between display, MNI, 

and Talairach coordinate systems.  Clicking on any point in the displayed image updates the 

coordinate values.  Similarly, a point can be entered for any coordinate system and set using the 

corresponding GO button.     

2.2 Generating masks using the PickAtlas Tool 

 The PickAtlas tool has basic (default) and advanced modes. The mode is set by choosing 

“basic” or “advanced” in the top middle column. In basic mode all areas are combined into a 

single union. In addition, any dilations (see section 2.8 Mask Dilation) are applied to all selected 

Figure 1.  PickAtlas GUI.  The left most pane lists the atlas types 

and is used for navigating the atlas subregions. The right most 

pane lists the selected regions.   
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regions. The advanced mode allows the user to combine unions and intersections and allows for 

differential dilations of selected subregions 

2.3 Generating a mask in basic mode 

 The user can select a region to be included in a 

mask by double clicking the label or by clicking the 

“add” button. Multiple regions can be added to the 

ROI. In the example presented (Figure 2) Brodmann’s 

areas 5 and 7 have been chosen. In addition, the 

regions have been dilated by using the 2D dilation 

function (note that in basic mode a dilation function is 

applied to ALL regions in the ROI). Selecting the 3D 

dilator results in a larger mask that is generated using 

a 3-D dilation function (Figure 3).  

 Masks can be limited to the right or left 

hemisphere by selecting “right” or “left” in the center 

column (Figure 4). The default is “Left + Right”. The 

flip function is located above the anatomic image and 

allows the user to convert from neurological to 

radiological format. To perform a flip, the “Flip 

Lock” button must be turned off and the “Flip” button 

turned on. After performing a flip the image will be displayed in radiological format. Note that 

the “R” and “L” indicators are also flipped to correspond with the image. Selecting “Done” will 

write the mask. 

 

 
 

 

Figure 4.  Right/Left selectors and Flip.  The right 

button selects only the right side of a mask.  The Flip 

button changes the display from Neurologic to Radiologic.  

Note that use of the Flip button will also affect the written 

mask.  The flip button can be accessed by untoggling the 

Flip Lock button.  See section on Flip toggle button. 

 

Figure 2.  Basic mode.  BA 5 and 7 have 

been selected with a dilation of 1. 

 

Figure 3.  2D and 3D dilation.   3D dilation 

grows the mask to a greater extent. 
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2.4 Generating a mask in advanced mode  

 Advanced mode includes 2 panes in the right column (Figure 5). The upper pane displays the 

regions for the current working ROI. The bottom pane displays any committed ROIs. Advanced 

mode can be used to generate a single mask image with multiple different ROIs. As with basic 

mode, the user can select a region to be included in a mask by double clicking or by highlighting 

(single click) the region and clicking the “add” button. Any combination of unions and/or 

intersections can be performed. A union is performed by selecting multiple regions in the right 

upper box (middle click or cntl + right click) and selecting union below the working region box. 

Similarly, an intersection can be performed using the intersection button. Any one region can be 

dilated independent of the other regions by highlighting the region in the working regions box 

and entering a dilation value in the dilation box. The dilation is applied by pressing enter. 

Dilations must be performed prior to unions or intersections. Once an ROI is complete, 

“commit” should be clicked and the ROI will be moved to the right lower box. This region will 

now be included in any final mask. Further ROIs can be generated and committed to the final 

mask. Selecting “Done” will write the mask. 

 

Figure 5.  Advanced Mode.  Figure demonstrates Advanced Mode use of the PickAtlas tool 

to generate ROIs for Frontal Eye Fields.  The final mask window in this example contains a 

region defined for the FEFs. This includes Brodmann areas 6 and 8 from the Brodmann area 

atlas. These areas were dilated by 3 (noted beside each area with (d 3)).  These were then 

joined using the Union feature.  The middle frontal gyrus was then selected from the TD label 

atlas and intersected with the union of BA 6 and 8 to generate the final ROI. Below the Final 

Mask window is an equation window that shows the operators applied to the subregions. A 

union is represented by a “+” and an intersection by a “*”. 
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2.5 Coordinate converter 

 The bottom portion of the GUI contains a coordinate converter.  Clicking on any point in the 

displayed image updates the coordinate values for cube coordinate space (display space), MNI 

space, and Talairach space.  Similarly, a point can be entered for any coordinate system and set 

using the corresponding GO button.  The selectors to the right of the coordinate display can be 

used to choose which atlas to display values from.  When available, alternate coordinate systems 

may be selected from the dropdown boxes to the left.  The Interrogate Talairach Daemon selector 

at the bottom of the GUI can be used to interrogate the Talairach Daemon directly over the 

internet when one of the coordinate sysmtems provides a Talairach transform.  This uses the 

talairach.jar file which should work on all java-compatible systems.  The selector at the right sets 

the search range (in mm) for interrogation of the Talairach Daemon.  Values from the Talairach 

Daemon are returned in the matlab command window.  The value boxes list the internal unique 

values assigned to the region from the selected atlas. These have no effect on the displayed mask, 

and are provided only for user interest.  

 

 

2.6 Mask Dilation 

 The Brodmann atlas areas define a relatively thin cortical strip.  In order to increase the 

volume of a masked area while maintaining its anatomic localization, we have incorporated the 

optional use of a morphologic dilatation operator using a unary 3x3 kernel.  Note that use of the 

dilation function currently requires the Matlab Image Processing Toolbox.  The user selects 

which regions to perform the dilation upon and the number of iterations before generating the 

final mask. When a dilation value is entered, the return key must be pressed for the dilation to 

take effect. This has the net effect of “growing” the region 1 voxel in each direction for every 

iteration of the dilatation function. This can be performed in 2D (in-plane) or 3D mode.   The 

statistical inference for multiple comparisons is then based on the area of the dilated mask.  In 

Basic Mode, all regions are dilated the same amount.  However, in advanced mode, there is the 

capability to dilate each region independently. This added functionality may be useful for 

generating an intersection of anatomic and cytoarchitectural subregions. For example, the 

superior parietal lobule could be intersected with a dilated Brodmann area 7.  Although the 

dilation function may extend the ROI beyond the strict anatomic borders defined by the atlas, the 

search region remains focused about the area of interest.  It is important, however, that the 

investigator notes any area of activation that extends beyond the anatomic area of interest, 

especially with a large number of iterations of the dilation function (i.e., greater than 3).  It is 

also important to treat the BA labels as candidate labels (within our atlas and the Talairach 

Daemon database atlas).  These labels represent a generalization from Brodmann’s descriptions 

as published in the 1988 atlas and rule-based boundaries assigned by the Talairach Daemon 

Figure 6.  Coordinate converter.  Located at the bottom of the pickatlas GUI.  Coordinates can be converted 

from display, MNI, or Talairach coordinate systems.  The Interrogate Talairach Daemon function will probe the 

Talairach daemon over an internet connection using the provided search radius (mm). 
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developers.  Although these labels provide a standardized approach to searches in spatially 

normalized images, they should not be overinterpreted as searching absolute anatomy. 

2.7 Shape Definition 

 TheWFU_PickAtlas software includes a shapes menu allowing creation of either spheres or 

boxes of user defined center, radius, and dimensions.  After clicking on the Shapes menu, a 

submenu for Sphere and Box will appear.  When Sphere is clicked on, several new buttons in the 

center column will appear for defining the radius of the sphere and generating the object.  The 

center can be user-defined by either clicking on the displayed image, or by directly inputting 

coordinates into the coordinate converter (at the bottom of the GUI).  The coordinates can be 

input in either cube space, MNI space, or Talairach space. 

 

 

 

 

 

 

 

 

 Similarly, when the Box shape is clicked on, 

several new buttons will appear in the center 

column for defining the x,y and z dimensions (in 

mm).  The center can be defined in a similar fashion 

as for the Spheres.  Once a shape has been defined, 

it is available throughout the remainder of the 

session as a region that can be added or removed, 

with the full functionality of Basic and Advanced 

modes.  Any defined shapes are given a new name 

based on the type of shape, and the shape 

dimensions.  These generated shapes appear as 

objects under the Shapes submenu during the 

current WFU_PickAtlas session.  A maximum of 

32 shapes can be defined.   

 

 

 

 

 

 

 

 

 

 

Figure 7.  Shapes submenu.  Spheres and boxes can be generated. 

Figure 9 Shape definition.  When a shape is created, it is labeled and is available for the 

remainder of the session just as any other region in the atlas.  Shapes are labeled based on shape 

type, center, and dimensions. 

Figure 8.  Shapes generation.  Sphere radius 

and Box dimensions can be defined.  Center is 

determined by inputting coordinates or by 

clicking on image. 
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2.8 Table Generation 

 The Generate Table function will apply the selected ROI to an image (or list of images) and 

create a tab-delimited text file listing some basic statistics for the selected region.  A file 

selection GUI will open allowing the user to select individual images.  Alternatively, a text file 

containing a list of images (with full path names) can also be selected. 

2.9 Command line use 

 The PickAtlas tool can be invoked from the matlab command line by entering: 

 

Command line usage 
[regions,mask,filename] = wfu_pickatlas; 

 

The regions, mask and filename variables are optional outputs.  Regions is a structure 

containing the selected regions.  Mask contains the mask volume.  Filename is the output 

filename.  The routine can simply be called with:   

 

Lauching the PickAtlas from the Matlab command prompt 
wfu_pickatlas; 
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3 ROI Analysis 

3.1 Performing atlas-based ROI analyses in SPM: 

 For SPM-based analyses, the ROI analysis 

feature has been moved from the SPM Results 

GUI to the pickatlas toolbox dropdown. Once 

the PickAtlas toolbox has been correctly 

installed, the wfu_pickatlas will be appear as a 

toolbox option under the toolbox dropdown as 

shown in Figure 10.  Start the wfu_pickatlas 

toolbox.  The PickAtlas will have a button in 

the central column of the screen called 

ANALYSIS as shown in Figure 11.  When the 

PickAtlas is started outside SPM, the button will not appear (see section 4 on “Results Viewer” 

for use outside of SPM).  Selecting the ANALYSIS button will present a series of questions as if 

the “Results” button within SPM had been pressed.  At the end of the results selection, the user 

will be prompted to select where the ROI for the analysis is to come from (Figure 11).  This is 

presented as “ROI analysis from” with the 

options “Saved File” and “Pickatlas GUI” 

buttons are presented. Each option is selected 

by clicking on the appropriate button. After 

the selection of a mask file or the creation of a 

new mask from the PickAtlas Tool the results 

process will continue but will be restricted to 

the region(s) contained in the mask file. The 

only change that will be noticeable to the user 

from this point on is that the mask will be 

resliced and a completion meter will be displayed during this process. Because the mask area is 

generally smaller than the whole brain, the number of multiple comparisons will be reduced. 

Thus, results viewed using the PickAtlas Tool will include a small volume correction that will be 

reflected in the p-values. 

3.2 Selecting a saved mask file 

If the user selects “saved File” then an 

SPM file selector GUI will open and the user 

will be able to select any NIfTI or Analyze 

file. A Mask can be generated and saved using the PickAtlas Tool or can be generated using any 

method as long as it is normalized to MNI space and in NIfTI or Analyze format. After selecting 

a mask file the results process will continue.  

3.3 Selecting an ROI using the PickAtlas 

If the user selects “Pickatlas GUI”, then the PickAtlas will open without an ANALYSIS or 

RESULTS button.  See section 2 for creating masks with the PickAtlas.  When “Done” is 

Figure 11 ROI Results selector 

Figure 10 Toolbox Selector with wfu_pickatlas 

selected 

Figure 11 Left: PickAtlas started from within SPM 

enabling the ANALYSIS button.  Right: PickAtlas 

started outside SPM disabling the ANALYSIS button. 
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selected in the PickAtlas, the ROI will be saved as NIfTI pair named atlas_mask_file.img in the 

SPM.mat directory.  The results process continues from this point. 

 

4 Using Results Viewer 
The Results viewer allows users either within or outside of SPM to use the SPM inference engine 

for performing ROI-based analyses, thresholding and viewing of their data.  

 

4.1 Starting the Results Viewer 
 The PickAtlas Results Viewer may be started from the PickAtlas GUI by selecting the 

RESULTS button.  The RESULTS button will not appear if more than one PickAtlas is open at a 

time. 

 

4.2 The Results Viewer Interface 
 

 
 

The PickAtlas Results Viewer (Figure 12) consists of menu bar and three areas for 

interaction.   

 

From the menu bar a statistical image may be loaded.  Currently SPM, FSL, and AFNI 

datasets are imported with ease from File -> Open.  Images from other statistical packages may 

also be opened with the user providing more input such as degrees of freedom and FWHM.  The 

current session may also be saved for easy retrieval using File -> Save Session and loaded using 

Figure 12 PickAtlas Results Viewer with sample SPM.mat loaded with an ROI from the 

PickAtlas of the right hemisphere. 
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File -> Load Previous Session.  The reports show in the bottom results area my be saved to an 

image (png, jpg, etc.) or text form using File -> Save Report. 

The Options menu item allows changing the atlas or background image.  Options also allows 

left/right flip and up/down flip.  From here one can also set the default compute preferences and 

mouse handling.  These preferences can be saved for the next session using Options -> Save 

Options for Next Session. 

The Help menu item allows showing atlas information. 

 

The upper left corner of the display area contains options affecting computation in the 

analysis or showing of labels.  The first row allows selection of up to three atlases when viewing 

labels.  ROI allows selection of an ROI from the PickAtlas or from a file.  The six possible 

buttons display: 

 Whole Brain Stats – Statistics for all clusters. 

 Single Cluster Stats – Statistics for the currently selected cluster in the brain view.  The 

pointer will move to the closest cluster selected by mouse click. 

 Whole Brain Labels – Labels, number of voxels, and other brief statistics for all clusters 

in the brain.  The labels shown are from the three atlas buttons at the top. 

 Single Cluster Labels – Shows labels and brief statistics for the currently selected cluster.  

The pointer will move to the closest cluster selected by mouse click. See Figure 13a. 

 Show ROI – Replace activations on the brain with a white mask showing the extent of the 

ROI choosen by the ROI option.  See Figure 13b. 

 Single Cluster TimeCourse – Only available for SPM statistics.  Shows a cluster’s mean 

and peak voxel timecourse.  Optionally, the paradigm may be shown against the 

timecourse.  See Figure 14. 

 
Figure 13a Single Cluster Labels 

Figure 13b Show ROI 



WFU Pickatlas 

v  3.0.5 
maldjian@wfubmc.edu 

 

14 

 

 
 

The upper right contains a brain image that may be navigated using the slider.  Optionally 

the brain may be manipulated through mouse scrollwhell and/or click and drag.  These 

settings are set in the menu under options. 

 

 The bottom contains results dependent on button selection above it. 

 

4.3 The sample dataset  
 Below are examples in opening data processed in SPM, FSL, and AFNI.  The sample dataset 

is available online.  Instructions on how each set was processed is included below.  The images 

below show the Whole Brain Stats which allow for comparison. 

 

4.4 SPM dataset 
 The SPM8 dataset was created through the SPM batch script found in the sample data at 

processing-spm/BatchProcssing.m.  This is the simplest dataset to open.  Select File-> Open,  

then select the desired SPM.mat.  If the SPM.mat is not stored where its internal pointers 

indicate, then a message will allow you to keep this pointer or use the current directory where the 

SPM.mat is found.  SPM dataset will allow you to open the timecourse file if desired.  If the 

timecourse can be easily found the program will open it or it will prompt you to select the correct 

timecourse file.  Whole brain statistics may be seen in figure 12. 

 

4.5 FSL dataset 
 The FSL dataset was created with the feat file processing-fsl/paradigm.fsf.  Additional steps 

are required to transform the statistics and mask into MNI space if the data is not pre-normalized.  

The sample data is in native space and had to have these additional steps.  The full processing 

script is below.  Lines are wrapped that end with a backslash. 

 

 

Figure 14 Single Cluster time course with Paradigm Overlay 
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FSL processing commands 
Commands issued while in the samples/processing-fsl directory: 

bet structural.nii structural_brain.nii 

feat paradigm.fsf 

flirt -in structural.nii -ref ${FSLDIR}/data/standard/MNI152_T1_2mm_brain \ 

    -out structural_MNI152 -applyxfm -init fmri.feat/reg/highres2standard.mat 

cd fmri.feat 

flirt -in mask.nii.gz -ref ${FSLDIR}/data/standard/MNI152_T1_2mm_brain \ 

    -out mask_MNI152 -applyxfm -init reg/example_func2standard.mat 

cd stats 

flirt -in tstat1.nii.gz -ref ${FSLDIR}/data/standard/MNI152_T1_2mm_brain \ 

    -out tstat1_MNI152 -applyxfm -init ../reg/example_func2standard.mat 

flirt -in zstat1.nii.gz -ref ${FSLDIR}/data/standard/MNI152_T1_2mm_brain \ 

    -out zstat1_MNI152 -applyxfm -init ../reg/example_func2standard.mat 

 

Opening an FSL dataset is started by selecting File -> Open.  Then select a normalized 

statistical image from the stats directory.  The image should be recognized as FSL, but the 

Results Viewer will allow you to choose opening this file as an FSL Feat dataset or as a single 

image.  If the FSL Feat dataset is selected, then appropriate information from the dataset will be 

entered into the import screen (Figure 15).  Missing information will have to be entered 

manually.  Results will then be shown in the Results Viewer (Figure 16). 

 

 

Figure 15 FSL dataset open dialog 
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4.6 AFNI dataset 
The AFNI dataset was created purely though the command line.  The BRIKs created by 

AFNI have to be normalized and converted to Nifti in order to display in the results viewer.  The 

full processing script is below.  Lines are wrapped that end with a backslash. 

 
AFNI processing commands 

Commands issued in the samples/processing-afni directory: 

3dcopy structural.nii structural 

3drefit -spgr structural+orig 

3dcopy fmri.nii fmri 

3dvolreg -prefix fmri_vr -tshift -Fourier -verbose -base fmri+orig'[0]' \ 

    -dfile fmri_motion.txt fmri+orig 

1dplot -volreg fmri_motion.txt'[1..6]' 

3dmerge -1blur_fwhm 8 -doall -session . -prefix fmri_vr_8mm fmri_vr+orig 

3dDeconvolve -input fmri_vr+orig -nfirst 0 -polort 2 -num_stimts 2 \ 

    -basis_normall 1 -stim_times 1 task.1D 'BLOCK4(30)' \ 

    -stim_label 1 task -stim_times 2 control.1D 'BLOCK4(30)' \ 

    -stim_label 2 control -num_glt 1 -glt_label 1 task_on \ 

    -gltsym 'SYM: -control +task' -fitts fit_ts -errts error_ts \ 

    -xjpeg glm_matrix.jpg -tout -fout -bucket glm_out 

@auto_tlrc -base TT_avg152T1+tlrc -suffix _avg152T1 \ 

    -input structural+orig -ok_notice 

@auto_tlrc -apar structural_avg152T1+tlrc -input glm_out+orig \ 

    -suffix _avg152T1 

Figure 16 FSL dataset Whole Brain Statistics 
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@auto_tlrc -apar structural_avg152T1+tlrc -input fmri+orig \ 

    -suffix _avg152T1 

3dAFNItoNIFTI structural_avg152T1+tlrc 

3dAFNItoNIFTI -float glm_out_avg152T1+tlrc 

3dAFNItoNIFTI fmri_avg152T1+tlrc 

 

Opening an AFNI data is started by selecting File -> Open.  Then select the normalized 

statistical image.  In the example dataset it is named glm_out_avg152T1.nii.  The image should 

be recognized as AFNI, but the Results Viewer will allow you to choose opening the file as an 

AFNI dataset or a single image.  If the AFNI dataset is selected, then appropriate information 

from the image file will be entered into the import screen (Figure 17).  Missing information will 

have to be entered manually.  Results will then be shown in the Results Viewer (Figure 18). 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

Figure 17 AFNI dataset open dialog 
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5. Technical Notes 

5.1 Integration with SPM 

 The PickAtlas routine was integrated into the SPM software environment by using the 

standard toolbox method.  Prior to version 3, the PickAtlas used modified spm_getSPM.m file.  

This version does not. To perform an ROI analysis, one must start the pickatlas from the 

toolbox and select ANALYSIS.  An SPM.mat is selected and the user is asked to mask via a 

previously made image or from the PickAtlas.  The selected mask is applied to the desired SPM 

contrast image prior to viewing.  In addition, when an atlas_mask is selected, the SPM small 

volume correction is automatically implemented on the basis of the mask limiting the number of 

multiple statistical comparisons for more robust inference. 

Figure 18 AFNI dataset Whole Brain Statistics 
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5.2 Atlas Modifications 

 The last uniquely labeled slice returned from the Talairach Daemon is at Talairach Z-

coordinate = 65.  The information returned from slice 66 is identical to that at slice 65, and 

nearly identical at slice 67.  There is approximately 1 cm of additional brain tissue in the Z-

direction that is unlabeled.  This region encompasses the superior-most extent of the 

sensorimotor cortex and includes portions of Brodmann areas 1, 2, 3, 4, 5 and 6.  In MNI-space, 

the Talairach Daemon atlas labels terminate in a partial slice at MNI Z-coordinate 72.  In order to 

complete the atlas to the vertex in MNI space, we replicated the last completely labeled slice 

(MNI Z-coordinate 71) with a 0.9 demagnification factor for successive slices in the Z-direction 

(MNI Z coordinate 72-78).  Since Brodmann areas 1, 2, 3, 4, 5 and 6 continue to the vertex, this 

approach affords a good approximation for the intracranial contents.  We have saved non-

modified versions of the atlases as well. 

5.3 Accessing the atlases 

 The segmented atlases are saved as unsigned byte or integer data NIfTI volumes in the 

MNI_atlas_templates subdirectory with their corresponding lookup tables.  The atlases are in 

MNI space with dimensions of 91x109x91 sampled at 2 mm intervals, corresponding to the SPM 

MNI templates.  The atlases are in neurologic convention (right of image = right of subject).  

Coordinates were converted from Talairach space using a nonlinear transformation originally 

described by Matthew Brett (www.mrc-cbu.cam.ac.uk/Imaging/mnispace.html) [6].  Although 

there is no published clear validation of this transform, it is widely used to convert from SPM99-

MNI coordinates to Talairach space.  ANALYZE format (Mayo Clinic, Rochester USA) images 

are available under the MNI_atlas_templates\legacy directory. 
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